memory limit blijft op 40mb

Technische problemen? Hier kun jij jouw vragen stellen!
Forumregels
Check eerst even onze handleiding (http://help.antagonist.nl/) voordat je hier je vraag stelt. Voor de meeste problemen hebben we een oplossing met een zeer uitgebreide uitleg.
Plaats reactie
knireis
Berichten: 70
Lid geworden op: 01 sep 2009, 13:44

memory limit blijft op 40mb

Bericht door knireis » 18 dec 2016, 22:06

Ik heb wat problemen met een plugin en de developer vraagt wat de memory limit is. Volgens de sysinfo van deze plugin is het 40mb. In direct admin heb ik het op 1024 gezet, maar dat helpt dus niet. Evenzo een aanpassing in .htaccess of wp-config.php. Vraag is waarom blijft het daar op 40mb staan?

knireis
Berichten: 70
Lid geworden op: 01 sep 2009, 13:44

Re: memory limit blijft op 40mb

Bericht door knireis » 19 dec 2016, 08:31

Ik heb nog eens zitten spitten en vind een bestand 'default-constants.php' in de map 'wp-includes'.

Als ik daar de memory limit aanpas, zie ik het wel terug in de sysinfo van de plugin.

Wat doet dit bestand en moet je die blijkbaar ook wijzigen om de setting van Direct admin effectief te laten worden?

Gebruikersavatar
Joris de Leeuw
Antagonist staff
Berichten: 1148
Lid geworden op: 13 feb 2016, 20:15

Re: memory limit blijft op 40mb

Bericht door Joris de Leeuw » 19 dec 2016, 14:00

Beste Knireis,

Vervelend om te lezen dat het ophogen van de PHP-versie niet werkt. Graag denk ik met je mee wat er aan de hand kan zijn.

Aangezien ik verder je website niet ken kan ik je niet exact vertellen waar dit spaak loopt. Indien je gebruik maakt van de nieuwste WordPress versie wordt de gekozen geheugenlimiet vanuit PHP direct gepakt. Oudere WordPress versies doen dit niet. Belangrijk is dus dat je website up-to-date is.

Dankzij onze huidige containerisatie binnen ons platform kan je namelijk zelf de geheugenlimiet (memory_limit) van PHP aanpassen. Je kan dit op de volgende manier doen:

1. Ga naar DirectAdmin
2. Ga onder Advanced Features naar Select PHP version
3. Show PHP Settings
4. Pas memory_limit aan van 96M naar bijvoorbeeld 128M
5. Druk onderaan op Save
6. De wijziging wordt doorgevoerd en PHP heeft meer werkgeheugen ter beschikking.

Mocht WordPress de limiet van 128 MB dan nog niet zien kan je bovenaan in het wp-config.php-bestand van je WordPress website het volgende zetten:

define('WP_MEMORY_LIMIT', '128M');

Graag wil ik je er op wijzen dat het kiezen van 1024 MB als geheugenlimiet van je pakket voor PHP is afgeraden. Door de limiet zo hoog te zetten kan een inefficient of zwaar PHP-script in een keer 1024 MB geheugen van je pakket opslokken, waardoor geen geheugen meer vrij is voor andere processen. Je loopt hierbij het risico dat je website voor andere bezoekers niet laadt.

Je dient de limiet die je laag instelt dus vooral ook zien als limiet die voorkomt dat een PHP-proces zomaar 'oneindig' geheugen kan gebruiken door incorrecte werking. Het instellen van de geheugenlimiet op 128 MB is meestal afdoende.

Mocht je spaak lopen met het achterhalen van de oorzaak stuur dan gerust een e-mail naar support@antagonist.nl. Dan helpen we je graag nog verder op weg bij het achterhalen van de oorzaak.
Met vriendelijke groet,

Joris de Leeuw
Antagonist staff

Plaats reactie