Pagina 1 van 1

Upgrade Wordpress gaat fout, wat nu?

Geplaatst: 12 jan 2018, 09:49
door ASS-Ware
Ik heb een Wordpress website (www.vrijmetselarijzeeland.nl) van een andere hoster geïmporteerd in een nieuwe user in mijn resellerpakket, welke op een oude versie Wordpress draait.
Om deze goed te laten werken moest ik terugschakelen naar php 5.6.
Doe ik een upgrade, dan krijg ik onderstaande foutmelding in de mail.
Hoe kan ik nu het beste de upgrade doen?

Melding:

This is an automated email from Installatron. To unsubscribe from these emails or to change notification settings, login to your web hosting control panel, navigate to the Installatron tool, and select the installed applications you wish to modify.

The update process for Vrijmetselarij Zeeland located at http://www.vrijmetselarijzeeland.nl has failed and the details of the failure have been logged.

Technical error:
Error: field_version: The selected version, or a version between it and the installed version, does not support upgrading. Check the application's website to see if a "migration" tool is available.

End of report.

Re: Upgrade Wordpress gaat fout, wat nu?

Geplaatst: 12 jan 2018, 11:59
door Joris de Leeuw
Hallo,

De melding geeft aan dat Installatron de upgrade tussen de betreffende versies niet direct ondersteund. Dit gebeurt meestal doordat de verschillen tussen deze versies te groot zijn.

Mocht je een enorme upgrade uitvoeren kan dit soms spaak lopen. Het beste kan je dan in kleinere stappen de WordPress website proberen te upgraden naar nieuwere versies en ondertussen nog kijken of de website goed blijft werken.

Bijvoorbeeld door zo te upgraden tussen meerdere versies:
3.8.0 --> 4.2.0 --> 4.6.0 --> 4.9.1

Indien je zeer lange tijd een website niet hebt bijgewerkt zul je vaak zien dat bij enorme upgrades bepaalde functionaliteiten zoals plugins en thema's niet meer goed worden ondersteund. Het beste kan je dit soort upgrades gefaseerd uitvoeren.

Re: Upgrade Wordpress gaat fout, wat nu?

Geplaatst: 12 jan 2018, 13:47
door ASS-Ware
Waar vind ik dan de opties om naar tussenliggende versies te updaten?
Ik kan updaten vanuit DirectAdmin en vanuit de /wp-admin, maar beiden gaan direct naar de laatste versie.

Re: Upgrade Wordpress gaat fout, wat nu?

Geplaatst: 12 jan 2018, 15:08
door Joris de Leeuw
Mocht automatisch updaten in één keer niet werken omdat de gebruikte WordPress versie zeer oud is heb je de volgende opties:

Optie 1. Gefaseerd updaten via Installatron. Je kan daarbij bijvoorbeeld plugins/thema's wel of niet direct mee upgraden: https://www.antagonist.nl/help/nl/websi ... on/upgrade
Optie 2. Handmatig updaten naar de nieuwere versies: https://codex.wordpress.org/Updating_WordPress

Indien een website voor zeer lange tijd niet is bijgewerkt zul je namelijk merken dat automatisch updaten niet altijd kan. Dit omdat verschillen te groot zijn om dit geautomatiseerd te overbruggen.

Al begrijp ik dat het geen gewenste oplossing is kan je dan overwegen in stappen (handmatig) te updaten.

Hopelijk kan deze tips je verder helpen!

Re: Upgrade Wordpress gaat fout, wat nu?

Geplaatst: 12 jan 2018, 21:01
door ASS-Ware
Met deze tips is het gelukt op een testsite, hardstikke bedankt.

Re: Upgrade Wordpress gaat fout, wat nu?

Geplaatst: 13 jan 2018, 12:33
door Joris de Leeuw
Goed om te lezen dat je er bent uitgekomen mede dankzij mijn tips!